Monday, July 26, 2010

AIX tools for SAP Administrators Set 5

Check APAR Level
instfix is used to install filesets associated with keywords or fixes.
instfix -i | grep
***********************************************************************************
Check concurrent io settings on oracle filesystems
lsfs |grep cio
To change the filesystems to CIO mounts execute the following scripts
Script1:
lsfs -c |grep sapdata|cut -d":" -f 1|while read f
do
chfs -a options=cio $f
umount $f
mount $f
done

Script 2
lsfs -c |grep [mirr,orig]log[A,B]|cut -d":" -f 1|while read f
do
chfs -a options=cio $f
umount $f
mount $f
done


***********************************************************************************
Setting Max Processes allowed per User
The parameter maxuproc defines this.
To check the current value
lsdev -El sys0
To change the parameter maxuproc
chdev -l sys0 -a maxuproc=
***********************************************************************************
The xhost program is used to add or revert access to the X server for specified hosts. This connection / port is used by VNC, X Manager.
All connection from all the server with the following command
xhost +
or
xhost +
***********************************************************************************
slibclean
/usr/bin/slibclean
Removes any currently unused modules in kernel and library memory.
This unloads all object files with load and use counts of 0. It can also be used to remove object files that are no longer used from both the shared library region and in the shared library and kernel text regions by removing object files that are no longer required.

No comments:

Post a Comment